DalPay's Sites Not Impacted by The 'Heartbleed Bug'

secure.dalpay.is and www.dalpay.com which we use to secure customer data were/are not vulnerable to the Heartbleed Bug because they have never run on OpenSSL 1.0.1 or 1.0.2-beta, but use earlier non-vulnerable versions.

At no time has customer or payment data (including account logins) been at risk from the Heartbleed Bug on any DalPay site.

Regarding the impact of the 'Heartbleed Bug' on other websites, and your use of mobile devices, we suggest regularly checking the official Heartbleed Bug website, and sites such as Krebs on Security.

Posted on 04.11.2014